超级大乐透开奖结果|超级大乐透几点开奖
理想論壇 » 指標編寫互助答疑區 » 請老師幫助編寫個突破上軌道買進的預警公式
倒序瀏覽 關注主題

請老師幫助編寫個突破上軌道買進的預警公式[通達信]

st0988 高一級同學(菠菜一段) 發表于 2019-4-20 23:16 樓主 只看
{連結MACD相鄰紅綠柱區間內高低點畫趨勢線 通達信}

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA1:=EMA(DIFF,9);

N11:=BARSLAST(CROSS(DIFF,DEA1))+1;{最近一次滿足條件DIFF上穿DEA的K線到當前的距離}
N21:=BARSLAST(CROSS(DEA1,DIFF))+1;{最近一次滿足條件DIFF下穿DEA的K線到當前的距離}


{當前是DIFF>DEA的狀態,連結最近兩個DIFF>DEA區間(不包含當前區間)內最高點的趨勢線}
A11:=BACKSET(ISLASTBAR && N11<N21,REF(REF(HHVBARS(H,N11)+1,N21),N21)+REF(N21,N21)+N21);
B11:=BACKSET(ISLASTBAR && N11<N21,REF(HHVBARS(H,N11),N21)+N21+1);
DRAWLINE(CROSS(A11,0.5),H,CROSS(B11,0.5),H,1)LINETHICK1,COLORRED;

{當前是DIFF>DEA的狀態,連結最近兩個DIFF<DEA區間內最低點的趨勢線}
A21:=BACKSET(ISLASTBAR && N11<N21,REF(REF(LLVBARS(L,N21)+1,N11),N21)+REF(N11,N21)+N21);
B21:=BACKSET(ISLASTBAR && N11<N21,REF(LLVBARS(L,N21)+1,N11)+N11);
DRAWLINE(CROSS(A21,0.5),L,CROSS(B21,0.5),L,1)LINETHICK1,COLORBLUE;

{當前是DIFF<DEA的狀態,連結最近兩個DIFF<DEA區間(不包含當前區間)內最低點的趨勢線}
A31:=BACKSET(ISLASTBAR && N11>N21,REF(REF(LLVBARS(L,N21)+1,N11),N11)+REF(N11,N11)+N11);
B31:=BACKSET(ISLASTBAR && N11>N21,REF(LLVBARS(L,N21),N11)+N11+1);
DRAWLINE(CROSS(A31,0.5),L,CROSS(B31,0.5),L,1)LINETHICK1,COLORBLUE;

{當前是DIFF<DEA的狀態,連結最近兩個DIFF>DEA區間內最高點的趨勢線}
A41:=BACKSET(ISLASTBAR && N11>N21,REF(REF(HHVBARS(H,N11)+1,N21),N11)+REF(N21,N11)+N11);
B41:=BACKSET(ISLASTBAR && N11>N21,REF(HHVBARS(H,N11)+1,N21)+N21);
DRAWLINE(CROSS(A41,0.5),H,CROSS(B41,0.5),H,1)LINETHICK1,COLORRED;
DRAWTEXT_FIX(1,0.0,0.0,0,'突破上軌道買進, 突破下軌道賣出'),COLORBLUE;
附件: 您所在的用戶組無法下載或查看附件,請先登陸。如果您還不是本站會員,請先進行注冊,然后才能下載或查看。

4 2925
注冊111 大四級同學(菠菜一段) 發表于 2019-4-20 23:59 2樓 只看

回復 樓主 @st0988 的帖子

以漲停上上軌







回復:

@st0988
附件: 您所在的用戶組無法下載或查看附件,請先登陸。如果您還不是本站會員,請先進行注冊,然后才能下載或查看。

st0988 高一級同學(菠菜一段) 樓主 發表于 2019-4-21 09:04 3樓 只看
謝謝您!參照您的思路我把趨勢線鄉下的突破也加上了,并設置了第一次突破
引用:
原帖由 @注冊111 于 2019-4-20 23:59 發表 http://
以漲停上上軌







回復:

st0988    

st0988 高一級同學(菠菜一段) 樓主 發表于 2019-4-28 11:05 4樓 只看
老師您好;思路是:今年一季度的股東人數比上個季度股東人數減少30%的選股公式,謝謝 能幫我編制飛狐版的嗎
引用:
原帖由 @注冊111 于 2019-4-20 23:59 發表 http://
以漲停上上軌







回復:

st0988    

注冊111 大四級同學(菠菜一段) 發表于 2019-4-28 12:44 5樓 只看

回復 4樓 @st0988 的帖子

飛狐沒有這樣函數。 @st0988

回頂部 到頁底
超级大乐透开奖结果